How do I install VeryFit 2.0 for my Delvfire Ignite if Google Play is saying my device is not compatible?

If Google Play is blocking your device from installing the VeryFit 2.0 app, do the following:

  1. Open a web browser on your device and visit: https://apkpure.com/veryfit-2-0/com.veryfit.multi
  2. Download the VeryFit 2.0 app by clicking on the green button that says Download APK, this will download the app installer (an APK file) onto your device ready for you to install.
  3. If you get a warning about Unknown Sources you will need to open Settings > Security on your device and enable Allow Unknown Sources until you have finished installing the app.
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.